HackerRank Problem : Min Max Sum ( easy )
Problem : ( Link : Click here to visit this HackerRank problem page. )
Given five positive integers, find the minimum and maximum values that can be calculated by summing exactly four of the five integers. Then print the respective minimum and maximum values as a single line of two space-separated long integers.
Input Format
A single line of five space-separated integers.
Constraints
- Each integer is in the inclusive range .
Output Format
Print
two space-separated long integers denoting the respective minimum and
maximum values that can be calculated by summing exactly four of the five integers. (The output can be greater than 32 bit integer.)
Sample Input
1 2 3 4 5
Sample Output
10 14
Explanation
Our initial numbers are , , , , and . We can calculate the following sums using four of the five integers:- If we sum everything except , our sum is .
- If we sum everything except , our sum is .
- If we sum everything except , our sum is .
- If we sum everything except , our sum is .
- If we sum everything except , our sum is .
Hints: Beware of integer overflow! Use 64-bit Integer.
--------------------------------------------------------------------------------------------------------------------------------------------
Solution : (in C++ )
#include <cmath>
#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
#include <cstdint>
using namespace std;
int main()
{
int64_t arr[5];
int64_t temp, sum = 0;
for (int i = 0; i < 5; i++)
cin >> arr[i];
sort(arr, arr + 5);
for (int i = 0; i < 4; i++) {
sum += arr[i];
}
cout << sum << " ";
sum = 0;
for (int i = 1; i < 5; i++) {
sum += arr[i];
}
cout << sum;
return 0;
}
Comments
Post a Comment